Проблема с отображением  [РЕШЕНО]

Вопросы, связанные с предварительным просмотром и публикацией вашего сайта на WYSIWYG Web Builder.
Правила форума
1. Название темы должно кратко описывать суть вашего вопроса, темы типа: "Помогите", "Почему", "Что это", "Что-то глючит" - будут удаляться.
2. Задавая свой вопрос, постарайтесь предоставить максимум информации о проблеме, если есть возможность, приложите шаблон проекта *.wtp.
Подробнее: Правила создания новых тем и ответов на существующие темы.
Данный форум - это место обсуждения вопроса, а не техподдержка в классическом смысле. Все участники форума Web Builder по-русски с удовольствием вам помогут, если это будет в их силах.
Ответить
Аватара пользователя

Конструкторщик
Эксперт
Эксперт
Сообщения: 1407
Зарегистрирован: 06 фев 2012, 14:01
Версия Web Builder: 12.0.2

Re: Проблема с отображением

Сообщение Конструкторщик » 14 июн 2012, 23:16

magira писал(а):При предпросмотре сайта в IE-6, заметил, что файлы .png "потеряли" свою прозрачность (прозрачные места отображаются серым цветом).
Предпросмотр в Opera - норм. В свойствах страницы / "IE" не нашел версию 6, ставил IE-5 не помогло. И еще при кликании на ссыки панели навигации в просмотре страницы IE они не срабатывают, перейти по ссылке можно только через ПКМ.
Как можно сделать, чтобы прозрачные .png корректно отображались, а ссылки срабатывали и на "Ослике"?


Изображение
Однажды купивший-будет платить все время.

Реклама

Автор Темы
magira

Re: Проблема с отображением

Сообщение magira » 17 июн 2012, 00:50

Спасибо, с .png помогло, а вот с панелями навигации осталось, и кроме того они не отображаются (те которые со своим изображением), а по сделанным в программе- ЛКМ не срабатывает. Может ну его, для IE подгонять?

Аватара пользователя

Конструкторщик
Эксперт
Эксперт
Сообщения: 1407
Зарегистрирован: 06 фев 2012, 14:01
Версия Web Builder: 12.0.2

Re: Проблема с отображением

Сообщение Конструкторщик » 17 июн 2012, 17:09

magira писал(а):Спасибо, с .png помогло, а вот с панелями навигации осталось, и кроме того они не отображаются (те которые со своим изображением), а по сделанным в программе- ЛКМ не срабатывает. Может ну его, для IE подгонять?

IE-зло.
Я давно уже забил на него.
Как там что отбражается,нормальные (понимающие)пользователи IE не пользуются.
Однажды купивший-будет платить все время.


Автор Темы
magira

Re: Проблема с отображением

Сообщение magira » 18 июн 2012, 00:47

IE- зло, не зло, а есть и те кто им пользуется.. Все таки есть желание максимизировать и для "злого ослика". Вот не могу победить одну деталь: для кнопок панели навигации использую свое изображение, и их в IE вообще не видно. Используемый фон кнопок в панели навигации, взятой из набора WWB - отображается. С параметрами "поиграл", ни чего не получилось. Мож кто "победит" - поделитесь.

Аватара пользователя

Vika
Опытный
Опытный
Сообщения: 634
Зарегистрирован: 03 мар 2012, 03:01
Версия Web Builder: 9
Имя: Виктория
Контактная информация:

Re: Проблема с отображением

Сообщение Vika » 18 июн 2012, 10:49

Привет. Проверьте название ваших картинок- кнопок.
У меня проблемы были с отображением картинок на прозрачном фоне из за того, что я выбрала не тот формат. В фотошопе я сохраняла сначала в пнг8, а надо было пнг24 выбрать. Попробуйте поменять формат ваших кнопок, может поможет.
Я использую на 2-х сайтах свои кнопки, проверяла в эксплорере, все отображается. Но IE я обновляю регулярно. Если у вас стоит старая версия 5 или 6 например, тогда не знаю чем помочь.

Аватара пользователя

Конструкторщик
Эксперт
Эксперт
Сообщения: 1407
Зарегистрирован: 06 фев 2012, 14:01
Версия Web Builder: 12.0.2

Re: Проблема с отображением

Сообщение Конструкторщик » 18 июн 2012, 11:13

magira писал(а):IE- зло, не зло, а есть и те кто им пользуется.. Все таки есть желание максимизировать и для "злого ослика". Вот не могу победить одну деталь: для кнопок панели навигации использую свое изображение, и их в IE вообще не видно. Используемый фон кнопок в панели навигации, взятой из набора WWB - отображается. С параметрами "поиграл", ни чего не получилось. Мож кто "победит" - поделитесь.

Попробуйте зайти вот сюда http://spasiboeva.ru/ через IE.
Я б такое на всех сайтах сделал :-)
Попробуй форматы изображений поменять..jpg-png-gif-bmp и т.д.
Мож поможет..
Однажды купивший-будет платить все время.

Аватара пользователя

Vika
Опытный
Опытный
Сообщения: 634
Зарегистрирован: 03 мар 2012, 03:01
Версия Web Builder: 9
Имя: Виктория
Контактная информация:

Re: Проблема с отображением

Сообщение Vika » 18 июн 2012, 11:23

Хаааа :bra_vo: молодцы !


Автор Темы
magira

Re: Проблема с отображением

Сообщение magira » 18 июн 2012, 21:00

Спасибо. Я сам IE никогда не пользовался (он сразу не привлек). Просто юзеры с IE не "застрянут" на моем сайте, соответственно - меньше посетителей, посещаемость и пр.
Я б такое на всех сайтах сделал
Только за! Сам не смогу сделать, а вот если скрипт сделать, который при "обнаружении" IE будет пересылать на нужную страницу (с более приветливым и вежливым сообщением), или сам сообщение выводить будет и поделиться им тут, то найдутся, кто его применит. Я первый поставлю себе...


Автор Темы
magira

Re: Проблема с отображением

Сообщение magira » 20 июн 2012, 01:26

Вот нашел скрипт-победитель по "вылавливанию" IE всех версий.
http://habrahabr.ru/post/50544/#comment_1328945

Код: Выделить всё

<script type="text/javascript">
 var IE='\v'=='v';
 if(IE) {
 // тут пишем обработчик для IE броузера
 }
 </script>


Автор Темы
magira

Re: Проблема с отображением

Сообщение magira » 23 июн 2012, 23:04

Извиняюсь, но я не могу успокоиться с темой заточки сайта по IE. (Ну в нашей корпоративке полно их еще, по-умолчанию...).
В общем при отображении в IE панели навигации (или управляемого изображения), если при включен эффект изчезновения одной картинки и появление другой, то при наведении мышки на неё рука не появляется, т.е. не срабатывает ссылка, при всех других эффектах работает. Что это, глюк моей версии WWB?

Аватара пользователя

Vika
Опытный
Опытный
Сообщения: 634
Зарегистрирован: 03 мар 2012, 03:01
Версия Web Builder: 9
Имя: Виктория
Контактная информация:

Re: Проблема с отображением

Сообщение Vika » 24 июн 2012, 00:41

Когда то я искала информацию по сайтостроению, часто попадались вопросы людей, которые именно под 5 версию и под 6 IE подгоняли сайты и с этим были проблемы. Скорей всего наша программа тут не при чем. Это допотопные браузеры выпендриваются. В наиболее свежей версии IE такого не должно быть. Проверить не трудно. А вот подогнать.....


Автор Темы
magira

Re: Проблема с отображением

Сообщение magira » 24 июн 2012, 23:12

"Подогнать" под IE6 можно - упростив сайт до самой простоты (без эффектов и пр.). В общем пока забил на это, установил страницу для входящих с IE, с предложением сначала установить норм.браузер, а потом зайти снова.
Кстати и в IE7 панели навигации не работают, только через ПКМ, поэтому нафик его...


Ответить

Вернуться в «Предварительный просмотр и публикация.»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей